GStreamer
open source multimedia framework
Home
Features
News
Annual Conference
Planet (Blogs)
Download
Applications
Security Center
GitLab
Developers
Documentation
Forum
File a Bug
Artwork
@gstreamer on Twitter
@gstreamer on Mastodon
#gstreamer on Matrix

Security Advisory 2023-0009 (ZDI-CAN-22226) (CVE-2023-44429)

Summary AV1 codec parser buffer overflow
Date 2023-11-13 12:00
Affected Versions GStreamer gst-plugins-bad < 1.22.7
ID GStreamer-SA-2023-0009
ZDI-CAN-22226
CVE-2023-44429

Details

Heap-based buffer overflow in the AV1 codec parser when handling certain malformed streams before GStreamer 1.22.7

Impact

It is possible for a malicious third party to trigger a crash in the application, and possibly also effect code execution through heap manipulation.

Threat mitigation

Workarounds

Solution

The gst-plugins-bad 1.22.7 releases address the issue. People using older branches of GStreamer should apply the patch and recompile.

References

The GStreamer project

CVE Database Entries

GStreamer 1.22.7 release

Patches


Report a problem on this page.