GStreamer
open source multimedia framework
Home
Features
News
Annual Conference
Planet (Blogs)
Download
Applications
Security Center
GitLab
Developers
Documentation
Mailing Lists
File a Bug
Bug Lists
Artwork
Follow @gstreamer on Twitter

Security Advisory 2021-0005

Summary Stack overflow in gst_ffmpeg_channel_layout_to_gst()
Date 2021-03-15 16:00
Affected Versions GStreamer gst-libav 1.x <= 1.18.3
ID GStreamer-SA-2021-0005

Details

GStreamer before 1.18.4 might cause stack corruptions with streams that have more than 64 audio channels

Impact

It might be possible for a malicious third party to trigger a crash in the application.

Threat mitigation

Workarounds

Solution

The gst-libav 1.18.4 release addresses the issue. People using older branches of GStreamer should apply the patch and recompile.

Report a problem on this page.