Differences between revisions 5 and 6
Revision 5 as of 2011-09-27 11:39:29
Size: 967
Editor: dsl-217-155-195-89
Comment:
Revision 6 as of 2011-11-30 06:35:30
Size: 879
Editor: 80
Comment:
Deletions are marked like this. Additions are marked like this.
Line 8: Line 8:
 * rename GST_BUFFER_FLAG_DELTA_UNIT to GST_BUFFER_FLAG_KEY_UNIT (and flag key units rather than delta units)?
Line 12: Line 11:
 * GstProbeType => GstPadProbeType ? (it's GstPadProbeCallback etc.)
 * GstProbeReturn => GstPadProbeReturn ?
 * ---(GstProbeType => GstPadProbeType ? (it's GstPadProbeCallback etc.))---
 * ---(GstProbeReturn => GstPadProbeReturn ?)---
Line 17: Line 16:
 * gst_adapter_unmap() flushes as well, better keep _flush() separate and explicit  * ---(gst_adapter_unmap() flushes as well, better keep _flush() separate and explicit)---

0.11 API Review/Notes

Core

GstBuffer

  • rename GST_BUFFER_FLAG_IN_CAPS to GST_BUFFER_FLAG_STREAMHEADER or so?

GstPad

GstAdapter

  • -gst_adapter_unmap() flushes as well, better keep _flush() separate and explicit-

Other

  • TODO: systematically check every single header file

Base

  • TODO

Base audio library

  • descriptions should not be part of the audio format struct, because that makes it hard/awkward to have them translated

Base video library

  • descriptions should not be part of the video format struct, because that makes it hard/awkward to have them translated

elements in core/base/good

  • TODO

ZeroPointEleven/APIReview (last edited 2011-11-30 06:35:30 by 80)