GStreamer
open source multimedia framework
Home
Features
News
Annual Conference
Planet (Blogs)
Download
Applications
Developers
Documentation
Mailing Lists
File a Bug
Bug Lists
Artwork
Follow @gstreamer on Twitter

Release notes for GStreamer Base Plugins 1.0.9

The GStreamer team is proud to announce a new bug-fix release in the 1.x stable series of the core of the GStreamer streaming media framework.

The 1.x series is a stable series targeted at end users. It is not API or ABI compatible with the stable 0.10.x series. It is, however, parallel installable with the 0.10.x series and will not affect an existing 0.10.x installation.

This module contains a set of reference plugins, base classes for other plugins, and helper libraries. It also includes essential elements such as audio and video format converters, and higher-level components like playbin, decodebin, encodebin, and discoverer. This module is kept up-to-date together with the core developments. Element writers should look at the elements in this module as a reference for their development. This module contains elements for, among others:

  • device plugins: x(v)imagesink, alsa, v4lsrc, cdparanoia
  • containers: ogg
  • codecs: vorbis, theora
  • text: textoverlay, subparse
  • sources: audiotestsrc, videotestsrc, giosrc
  • network: tcp
  • typefind functions
  • audio processing: audioconvert, adder, audiorate, audioresample, volume
  • visualisation: libvisual
  • video processing: videoconvert, videoscale
  • high-level components: playbin, uridecodebin, decodebin, encodebin, discoverer
  • libraries: app, audio, fft, pbutils, riff, rtp, rtsp, sdp, tag, video
Other modules containing plugins are:
gst-plugins-good
contains a set of well-supported plugins under our preferred license
gst-plugins-ugly
contains a set of well-supported plugins, but might pose problems for distributors
gst-plugins-bad
contains a set of less supported plugins that haven't passed the rigorous quality testing we expect, or are still missing documentation and/or unit tests
gst-libav
contains a set of codecs plugins based on libav (formerly gst-ffmpeg)

Features of this release

  • subparse: re-enable sami parser
  • tagdemux: fix ACCURATE seeks in push mode
  • multisocketsink, multifdsink: fix handling of partial writes and WOULD_BLOCK errors, and other fixes
  • audiodecoder: fix input caps leak

Bugs fixed in this release

  • 693056 : subparse: re-enable sami support
  • 704291 : riff: PNG AVI file does not play
  • 704301 : tagdemux: Breaks seeking forward fails if ACCURATE seek and push sources
  • 704926 : audiodecoder: leaks input caps

Download

You can find source releases of gst-plugins-base in the gst-plugins-base download directory.

The git repository and details how to clone it can be found at git.freedesktop.org.

Homepage

The project's website is http://gstreamer.freedesktop.org.

Support and Bugs

We use GNOME's bugzilla for bug reports and feature requests.

Please submit patches via bugzilla as well.

For help and support, please subscribe to and send questions to the gstreamer-devel mailing list (see below for details).

There is also a #gstreamer IRC channel on the Freenode IRC network.

Developers

Git is hosted on git.freedesktop.org. You can browse the gst-plugins-base repository.

All code is in Git and can be checked out from there.

Interested developers of the core library, plugins, and applications should subscribe to the gstreamer-devel list.

Contributors to this release

  • Edward Hervey
  • Matej Knopp
  • Olivier Crête
  • Reynaldo H. Verdejo Pinochet
  • Sebastian Dröge
  • Tim-Philipp Müller
  • Young-Ho Cha

Report a problem on this page.